AKAI Professional

Akai MPC Renaissance and Studio - Using as a plugin in Logic Pro


Rate this article

Article updated 08-02-2017

The MPC Renaissance and Studio include a powerful standalone MPC application.  You can also use the MPC software as a plugin within your favorite DAW such as Logic Pro.  This video guide walks you through everything you need to know about using the Akai MPC Renaissance or Studio plugin inside Logic Pro. 

 

 

 

 

 

Using the MPC Renaissance/Studio as a plugin in Logic Pro

 

Authorize in stand-alone app before using plugin mode

The MPC software authorization process occurs in the stand-alone version of the MPC application rather than in the plugin.  Before using the plugin, first launch the standalone version of the MPC application to authorize it.  For a complete walkthrough on authorizing the software, check out the following article:

 
Launching Logic Pro in 32-bit mode

As of version 1.1, the MPC software plugin the stand alone application 32-bit.  If you run Logic Pro in 64-bit mode, the MPC plugin will not function.  To launch the Logic Pro application in 32-bit mode, perform the following:

  1. Locate the Logic Pro application in the Applications folder on your Mac.  
  2. Click it once to highlight it.  
  3. With Logic Pro highlighted, press Command+I on your keyboard, or select File > Get Info to open the info window for Logic Pro.
  4. In the window that opens, make sure the Open in 32-bit mode option is checked.

    alt

    Note: if this option is not visible in the info window, you're running a 32-bit version of the Mac OS where all applications run in 32-bit mode.
     
  5. Close the info window, and double-click Logic Pro to launch it.

 

Loading the plugin and resizing the window
  1. In Logic, press Option+Command+N on your keyboard, or select Track > New to open the New Tracks window.
  2. In the window that opens, Select Software Instrument, and then click the Create button. A new software instrument track will be created.

    alt  
     
  3. In the lower-left of the screen above the channel volume slider, and below the words I/O, click and hold on the blank rectangle to select a plugin to assign to the track.  In the menu that opens, select AU Instruments > Akai MPC, and choose either the or the Multi Output (8xStereo) version of the plugin.

    alt  
     
  4. The MPC plugin will launch.  By default, the plugin window will be compact.  You can increase the size of the plugin by clicking and dragging the arrow in the lower-right corner of the window.
 
Mapping the transport controls
  1. In the MPC plugin, click on the Options Menu icon to the left of the to the Main and Program Edit tabs.

    alt  
     
  2. In the menu that opens, select Edit > Preferences.

    alt  
     
  3. On the left of the window that opens, select the Other tab.  Then set Hardware Transport C to DAW

    alt

    Selecting DAW for this setting allows the Record button on the MPC hardware to control the Record button out in Logic as opposed to the controlling the Record button inside the MPC plugin.  This is required while you map the transport controls.

    What's this setting for anyway?

    After you've mapped the transport controls, you'll set the Hardware Transport C setting back to Plugin if you want to record MIDI onto the tracks in the MPC plugin.

    Set the Hardware Transport C setting back to DAW any time you want to record MIDI onto tracks out in Logic instead of into the tracks in MPC plugin.  
     
  4. Out in Logic, select Logic Pro > Preferences > Key Commands or press Option+K on your keyboard to open the Key Commands window.
  5. In the window that opens, you'll map the following items in the Global Commands list to the transport buttons on the MPC hardware:
    • Record
    • Stop
    • Play
    • Rewind
    • Forward
  6. First, select Record in the Global Commands list,
  7. Click the Learn New Assignment button in the lower-right of the window. 

    alt

     Logic will now listen for the next MIDI message from any attached controllers.
     
  8. Press the Record button on the MPC hardware.  The Record button on the MPC will be mapped to the Record function in Logic Pro. 

    Note: when you are mapping these controls, the Logic software will react.  It will Record, Stop, Play etc when you press Record, Stop, Play Etc.  Just let this happen. Don't be alarmed, try to stop it, or make any extra clicks until you are done with the mapping.  Otherwise, you'll accidentally map extra controls incorrectly.
     
  9. After you've mapped the Record button (Logic will probably be recording now...just let it go), select the Stop function in the Global Commands list.  
  10. Click the Learn New Assignment button in the lower-right of the window. 
  11. Press the Stop button on the MPC hardware.  You've now mapped the Stop button.
  12. Select the Play function in the Global Commands list.  
  13. Click the Learn New Assignment button in the lower-right of the window. 
  14. Press the Play button on the MPC hardware.  You've now mapped the Play button.
  15. Next Select the Rewind function in the Global Commands list.  
  16. Click the Learn New Assignment button in the lower-right of the window. 
  17. Press the Event < button on the MPC hardware.  You've now mapped the Event < button.
  18. Next Select the Forward function in the Global Commands list.  
  19. Click the Learn New Assignment button in the lower-right of the window. 
  20. Press the Event > button on the MPC hardware.  You've now mapped the Event > button.

    Note: the Locate, <<, and >> buttons on the MPC hardware don't send messages to Logic.  They only send messages directly to the MPC plugin.  These controls cannot be mapped to other functions in Logic Pro.
     
  21. Now that you've mapped your transport functions, it is a good idea to save a Logic template for yourself so you don't have to remap these controls in the future.

    Select File > Save as Template to save your current project as a template to save you time in the future. Of course, you'll add other things to the templates you save, including your favorite track setups, favorite effects plugins, audio routing etc, until you've created the ultimate template for the way you work.

 

Using the Sample Record feature
  1. Connect an audio source to a physical input on the MPC hardware.
  2. Press SHIFT+SAMPLE REC on the MPC hardware to enter Sample Record Mode.
  3. In the upper-right of the MPC Plugin window in Logic Pro, select a Side Chain input that matches the physical input on the MPC hardware that you have connected your audio source to.

    alt 
     
  4. On the screen of the MPC hardware, set Monitor to ON.

    alt

  5. You're now ready to sample. Press F6 under the MPC hardware screen to begin recording a sample.

    To sample in stereo, check out this excellent video by AtlantaLogicTrainer. The section you're looking for begins at 8:22 in the video:


     

Using multi-output plugin options

If you selected the Multi Output (8xStereo) version when launching the plugin, you'll have additional output options.

  1. Select the Track Mixer tab at the top of the plugin window.
  2. Above the channel fader and Pan knob of each track is an output selection pull down menu. You can choose from among different available output options for each of your tracks.

    alt

    Tracks which are assigned to Out 3,4, Out 5,6, Out 7,8, Out 9,10, Out 11,12, Out 13,14, and Out 15,16 will be routed to auxiliary tracks out in Logic Pro's mixer.
     
  3. Out in Logic, open the Mixer by selecting Window > Mixer, or by pressing Command+2 on your keyboard.
  4. On the MPC's channel strip click the + button below the M and S buttons to reveal the additional output auxiliary channel strips.

    alt    alt

    Any tracks in your MPC Track Mixer that you have routed to different outputs will be reflected in the channel strips here in Logic's mixer.

 

Exporting all tracks as audio files

 

  1. To export these discrete outputs to separate audio files, you'll need to have some content in Logic's arrange window.  

    Select Window > Arrange or press Command+1 to return to the Arrange window.

    If you've been following along with this guide exactly, you may have only the one MPC track showing in your Arrange window.  It also probably has no MIDI showing in the timeline in the Arrange window (because any MIDI you've recorded so far is inside the MPC plugin).

    If all of the MIDI and audio in your project is occurring inside the MPC plugin, you'll need to add something to the timeline in the Logic Arrange window to proceed with the audio export.
     
  2. In the empty timeline to the right of your MPC track in the arrange window, right+click (or Control+click) in the blank space, and select Create Empty MIDI Region from the pull-down menu.

    alt  
     
  3. An empty MIDI region will be created in the timeline.  This lets Logic know your project is not totally empty, so you won't get a Nothing to bounce error when we try to export.
     
  4. Select File > Export > All Tracks as Audio Files. 
     
  5. In the window that opens, select a Save Format and Bit Depth.  Set Multi-Output Software Instruments to One File per Channel Strip.
     
  6. Click Save and your separate MPC outputs will be exported to discrete audio files.

 

 

Additional Resources

You can find a number of additional articles and videos in our knowledge base:

 

AKAI Technical Support and Warranty Service

Whether you are a customer or dealer, if you already own an Akai Pro product, or if you just have pre-sales questions, the Akai Pro technical support team is available to help!

Visit the link below to connect with any of the following support options: online community support, phone support, email support.

www.akaipro.com/support