About

MPC 2.0 is a major software release that provides support for Akai Professional’s revolutionary new MPC Live and MPC X. Version 2.0 vastly expands the software’s capabilities, adding audio tracks, real-time audio warping, and a new graphical user interface to improve your efficiency and the overall MPC experience. MPC 2.0 also provides many significant workflow enhancements and audio processing improvements.

All of us here at Akai Professional are continually updating and enhancing the MPC experience. This document lists the new features, fixes, and improvements in the MPC 2.0 beta software.

Support

Remember to check regularly for software and driver updates at akaipro.com

For additional product support, visit akaipro.com/support

Version 2.0 Beta (May 2017)

Important : This software is for 64-bit operation only.

This release can be controlled by MPC X, MPC Live, and MPC Touch. Support for MPC Renaissance, MPC Studio (black and standard models), and MPC Element will be in the official MPC 2.0 public release.

New Features

  • Hardware controllability: The MPC 2.0 beta release can be controlled by MPC X, MPC Live, and MPC Touch.
    • We’ve reworked and improved the MPC Touch interface.
    • MPC X and MPC Live can operate in Controller Mode to control MPC 2.0 software but with the same appearance as in Standalone Mode. In other words, you don’t have to dramatically change your workflow to use these products as controllers.
    • You can now configure the “switch” behavior of the Pad Bank buttons.
    • You can now switch the Tap Tempo button light off.
  • Audio Tracks: We’ve added audio recording and editing capability.
    • Multi-track recording: The software can now access up to 32 simultaneous mono inputs to record a multi-track performance.
    • New recording modes: Configure Punch-In and Record Start modes so you can start recording at a specific location mid-timeline.
    • Audio samples can be loaded or recorded into the familiar waveform-style editor (in the software window, click the Audiotab below the mode icons; in the touchscreen, tap the Audio tab in Main Mode, and enter Audio Edit Mode [waveform icon on the left]).
    • Audio samples can be dragged and dropped onto an audio track from your computer desktop or the software’s Browser.
    • A dedicated audio track channel strip controls the track’s level, panning, record-arm status, monitor, mute/solo status, effects, and more while recording and editing.
    • Audio editing enables you to split, duplicate, mute, or move regions of the audio track. You can also reverse, adjust levels, and pitch-shift separate track regions.
    • Warp functionality enables dynamic pitch- and time-stretching of audio regions.
    • Track View groups MIDI and audio tracks together in expandable/collapsible groups. You can also record to one or more audio tracks from within Track View.
    • Recorded audio can be warped automatically, ensuring it remains synchronized with any sequence tempo adjustments: go to Edit > Preferences > Other, and set Audio Tracks Auto Warp to On.
  • Clip Programs: This new program type enables you to trigger loops (clips) in freely assignable clip-mute groups.
    • Use Program Edit Mode to edit a clip—adjust clip length or BPM, add fade-ins/outs, reverse audio.
    • Program Edit Mode includes warp functionality to dynamically pitch- and time-stretch the clip to match key and tempo.
    • Clips can be launched in time with a sequence using the program’s quantization setting.
  • Touchscreen improvements (MPC Touch, MPC Live, and MPC X):
    • The Browser now contains shortcut icons to quickly find drum programs, keygroup instruments, clips, samples, demo projects, and other files. The new Search field enables browsing your directories by search term. Dual-pane layout speeds up workflow.
    • New shortcuts in Main Mode allow quick access to the most useful editing tasks.
    • You can now save projects, samples, etc. within the touchscreen.
    • You can set Preferences using the touchscreen (press Menu and tap the gear icon).
    • View your MPC controller hardware system resources—battery life, CPU meter, and available internal storage—by tapping the battery icon in the upper-right corner.
    • Channel Mixer’s Mute tab has been expanded to contain three options: Mute, Solo, and Rec Arm.
    • Scrolling is now inertial for more natural-feeling navigation.
  • Q-Link Edit Mode: You can assign parameters to the Q-Link knobs that will remain across all modes in the project. Press and hold the Q-Link button in any mode or screen to show and adjust the Q-Link knob assignments, improving your workflow throughout the software.   The Q-Link parameters can be in any of these modes:
    • Project: Assignable parameters on the Project level (i.e., any parameters within the project).
    • Program: Assignable parameters on the Program level (i.e., parameters within the current program). You can adjust the same 16 program parameters in whatever program you’re currently using.
    • Pad Scene: All 16 Q-Link knobs adjust 16 assignable parameters for the current pad—useful for fine- tuning the settings of each pad, one at a time.
    • Pad Parameter: All 16 Q-Link knobs adjust the same assigned parameter for all 16 pads—useful for “balancing” any one parameter’s values across all pads in a program.
    • Screen: The Q-Link-adjustable parameters that are shown on-screen (typical usage).
      Use the Learn function (in any Q-Link mode other than Screen) to quickly assign automatable parameters to the Q-Link knobs.
  • Audio engine:
    • Real-time time-stretching powered by zPlane Elastique or a custom MPC stretch algorithm. Select your preferred algorithm by going to Edit > Preferences > Other and clicking Audio Warp Algorithm.
    • You can now bounce tracks, sequences, or programs to a new sample or audio track within Main Mode.
    • You can now apply XYFX to the master channel (this now the default).
  • User interface: Completely new look and feel!
    • Zoomable enhancements: Quickly zoom horizontally in/out by clicking and dragging down/up on the blue timeline above the grid or wave display. Use the dedicated zoom key commands to further speed up your workflow.
    • Two “dynamic” channel strips on the left edge of the window show levels, panning, and effects for the pad, program, or track, depending on the current selection.
    • Current sequence, track, and program information is now always displayed in upper-left part of window. Click the menu icon in each section to choose how much or little information is shown.
    • Many areas of the interface are customizable, enabling you to show and hide panels as desired throughout the software window:
      • Show or hide Q-Link knobs, pads, parameters, project information, MIDI keyboard, or the entire lower panel.
      • Choose which modes’ icons are shown in the toolbar at the top of the window (View > Toolbar > Toolbar Modes).
      • The improved Browser panel can display the File Browser; Expansion Browser; or Media Browser; or be hidden entirely. You can also show or hide MPC content directories.
      • Media Browser: Browse the MPC 2.0 factory library and other Akai Professional Expansion libraries using a series of tag filters. The Search field further refines the results by search term.
      • The toolbar at the top of the window features extended transport controls (now with punch- in/out capability and on-screen Tap Tempo button). You can choose which ones are shown or hidden (View > Toolbar).
    • Timing Correct (TC) and Swing settings are added to the toolbar, so they’re accessible in any mode.
    • We’ve added a Help panel (?) to display quick explanations of on-screen elements when you hover the cursor over them.
    • We’ve streamlined Program Edit Mode for clarity, simplicity, and speed of use.
    • You can now use an eraser tool in the grid to erase events with a single click.
    • We’ve redesigned all channel strips to have selectable components and improved controllability.
    • Switch the upper editing panel between Grid, Wave, and List Views. The Grid View now displays your program’s pad colors. The new Wave View gives you access to key sample editing and warping parameters in most modes.
  • Keyboard shortcuts: We’ve added and streamlined all keyboard shortcuts to make your workflow more efficient throughout the software.
  • Quick renaming of keygroup samples: You can automatically rename all samples belonging to a keygroup based on their keygroup, layer, and other information: when using a keygroup program, go to Tools > Tidy Keygroup Sample Names.
  • CV programs (MPC X): Use MPC X to control external analog equipment via control voltage.
  • Track Exporting: You can now export tracks to patterns (.mpcpattern).
  • Stop All Sounds: You can now stop all sounds within the software by going to Tools > Stop All Sounds.

Improvements

  • Reorganized menu structure
  • Improved setup for program note-mapping
  • Overall performance improvements and bug fixes

Future Features

We will be continuing to improve the MPC experience over the beta period. Use the beta feedback button on the MPC software status bar to suggest a feature, report a bug or give feedback.